Java-Gaming.org Hi !
Featured games (91)
games approved by the League of Dukes
Games in Showcase (755)
Games in Android Showcase (229)
games submitted by our members
Games in WIP (842)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
 
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  Symbol Jump  (Read 5433 times)
0 Members and 1 Guest are viewing this topic.
Offline mrzli
« Posted 2014-10-25 18:15:19 »


This is simple Doodle Jump clone I made to better learn how to program using LibGdx and maybe convince a few people to try it.
It's actually my second game with the same vertical platform jumping gameplay, so it's a bit better than my previous try.
It's not very original, many things are similar to Doodle Jump, but there are a few new things in it.
Graphics is very simple and minimalistic because I did all of it and I suck at drawing.
If you want you can log into Facebook in-game and compare score to your friends if they also have this game installed.

HOW TO PLAY:
Tilt to move left or right. You cannot shoot or jump on enemies.

FEATURES:
There are several different platform types: stationary, moving, 'repositioning', crumbling, platforms that become visible for a short time when player jumps on any platform, various platform types with spikes, some combination of those features etc.
There are different enemy types with different kinds of movements.
There are two power-ups that make you go faster, I called them 'Anti-Gravity' and 'Rocket'. They work in a similar fashion, but Rocket is somewhat faster.
You can collect coins and use them to purchase upgrades which increase power-up duration.

Google Play: https://play.google.com/store/apps/details?id=com.symbolplay.tria.android&hl=en
Project description: http://goranm.com/portfolio/symboljump

QR Code:


Offline bornander
« Reply #1 - Posted 2014-10-26 18:45:42 »

It plays well and the bare-minimum graphics works works. Got 11448 points on my third try  Roll Eyes

There's something weird happening after I've played it two times though, it crashes when I click START. I can see the crash dialog flash past but I'm not given the option to send a stack dump. Clearing the data for the app seems to resolve the issue but it reappears after I've played it twice again.

Try my Android games: Grapple | Hovercraft | Lala
Offline mrzli
« Reply #2 - Posted 2014-10-26 19:55:41 »

Thank you for trying out the game and reporting this.

That's a pretty big problem, and I'd like to fix is asap if possible.
Unfortunately, I am unable to reproduce this. I tried playing 8 games in a row with scores 3-23 k on Galaxy S3 and 10 games in a row on some shitty Alcatel One Touch 4030X with scores 0.7-41 k and I had no issues.
I downloaded and used the version that is on Google Play.

I'd appreciate any more info you could give me.
Could you tell me what phone you use?
Can you go to options and for "Score lines" select "None", and see if this happens again? That is the only thing that comes to mind that affects reading of user data on "START".
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline kevglass

« JGO Spiffy Duke »


Medals: 319
Projects: 25
Exp: 22 years


Coder, Trainee Pixel Artist, Game Reviewer


« Reply #3 - Posted 2014-10-26 20:03:35 »

If you're hosting on Google Play your developer console will have recorded the stack trace from the crash for you.

Cheers,

Kev

Offline mrzli
« Reply #4 - Posted 2014-10-26 20:12:13 »

No crashes are reported at this time on my developer console. Seems that this crash was not recorded.
Offline bornander
« Reply #5 - Posted 2014-10-26 20:25:25 »

If you're hosting on Google Play your developer console will have recorded the stack trace from the crash for you.

Yeah, normally. I can see the dialog that asks me if I want to send a report but it only flashes past for a fraction of a second and then that's gone to. I tried it again whilst monitoring the log-cat output. Seems like there's an API issue, you're hitting a method I don't have on my shitty phone running Android 2.3.3.

I grabbed a screenshot of my stack for you;


Hope this helps.

Try my Android games: Grapple | Hovercraft | Lala
Offline mrzli
« Reply #6 - Posted 2014-10-26 20:39:04 »

That pretty much solves everything. Thanks a lot! I'll fix it and upload a new version.

Android sucks in this regard. I had the exact same problem on another game with String.isEmpty() which also exists only on some Android versions.

Is there a list of these methods that are not supported on all relevant Android Versions (2.2 and above)?
Offline mrzli
« Reply #7 - Posted 2014-10-26 21:23:29 »

I uploaded version 1.1.1 to Google Play that should fix this issue. As usual, it might take some time for this version to be available for download.
If there are any more problems or comments I'd love to hear it.

Thanks again.
Pages: [1]
  ignore  |  Print  
 
 

 
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!