Java-Gaming.org    
Featured games (81)
games approved by the League of Dukes
Games in Showcase (499)
Games in Android Showcase (118)
games submitted by our members
Games in WIP (567)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
 
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  Getting the test suite to run  (Read 1420 times)
0 Members and 1 Guest are viewing this topic.
Offline mrdale

Junior Newbie




Java games rock!


« Posted 2004-07-26 00:45:46 »

I think I've done all the acrobatics to get things compiled and placed where they belong yet still I get

    [java] Controller Env = net.java.games.input.DefaultControllerEnvironment@1004901
    [java] Scanning jar: dxinput.jar
    [java] Examining file : META-INF/
    [java] Examining file : META-INF/MANIFEST.MF
    [java] Examining file : net/
    [java] Examining file : net/java/
    [java] Examining file : net/java/games/
    [java] Examining file : net/java/games/input/
    [java] Examining file : net/java/games/input/DirectInputAxis.class
    [java] Examining file : net/java/games/input/DirectInputDevice.class
    [java] Examining file : net/java/games/input/DirectInputEnvironmentPlugin.class
    [java] Found candidate class: net/java/games/input/DirectInputEnvironmentPlugin.class
    [java] Adding class to plugins:net.java.games.input.DirectInputEnvironmentPlugin
    [java] Examining file : net/java/games/input/DirectInputKeyboard.class
    [java] Examining file : net/java/games/input/DirectInputMouse$BallAxis.class
    [java] Examining file : net/java/games/input/DirectInputMouse$BallImpl.class
    [java] Examining file : net/java/games/input/DirectInputMouse$ButtonImpl.class
    [java] Examining file : net/java/games/input/DirectInputMouse$ButtonsImpl.class
    [java] Examining file : net/java/games/input/DirectInputMouse.class
    [java] Examining file : net/java/games/input/DirectInputRumbler.class
    [java] java.lang.UnsatisfiedLinkError: getNumButtons
    [java]     at net.java.games.input.DirectInputMouse.getNumButtons(Native Method)
    [java]     at net.java.games.input.DirectInputMouse.access$200(DirectInputMouse.java:50)
    [java]     at net.java.games.input.DirectInputMouse$ButtonsImpl.<init>(DirectInputMouse.java:183)
    [java]     at net.java.games.input.DirectInputMouse.<init>(DirectInputMouse.java:88)
    [java]     at net.java.games.input.DirectInputMouse.createMouse(DirectInputMouse.java:146)
    [java]     at net.java.games.input.DirectInputEnvironmentPlugin.addDevice(DirectInputEnvironmentPlugin.java:159)
    [java]     at net.java.games.input.DirectInputEnvironmentPlugin.enumDevices(Native Method)
    [java]     at net.java.games.input.DirectInputEnvironmentPlugin.enumControllers(DirectInputEnvironmentPlugin.java:1
33)
    [java]     at net.java.games.input.DirectInputEnvironmentPlugin.<init>(DirectInputEnvironmentPlugin.java:113)
    [java]     at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    [java]     at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
    [java]     at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
    [java]     at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
    [java]     at java.lang.Class.newInstance0(Class.java:306)
    [java]     at java.lang.Class.newInstance(Class.java:259)
    [java]     at net.java.games.input.DefaultControllerEnvironment.scanControllersAt(DefaultControllerEnvironment.java
:208)
    [java]     at net.java.games.input.DefaultControllerEnvironment.scanControllers(DefaultControllerEnvironment.java:1
89)
    [java]     at net.java.games.input.DefaultControllerEnvironment.access$000(DefaultControllerEnvironment.java:58)
    [java]     at net.java.games.input.DefaultControllerEnvironment$1.run(DefaultControllerEnvironment.java:109)
    [java]     at java.security.AccessController.doPrivileged(Native Method)
    [java]     at net.java.games.input.DefaultControllerEnvironment.getControllers(DefaultControllerEnvironment.java:10
7)
    [java]     at net.java.games.input.test.ControllerTextTest.<init>(ControllerTextTest.java:54)
    [java]     at net.java.games.input.test.ControllerTextTest.main(ControllerTextTest.java:86)
    [java] Exception in thread "main"
when I try to use ant to run any of the tests.  Any clue which wrong turn I made?

Thanks,
Dale.
Offline TheBohemian

Junior Member




Java will rule them all!


« Reply #1 - Posted 2004-07-26 09:53:49 »

Quote

java.lang.UnsatisfiedLinkError: getNumButtons

This looks like an error on the JInput side of things ...
endolf?

cya

TheBohemian

---------------------------------------
my favorite OS: http://jnode.sf.net
Java 1.5 -> 1.4 converter: http://retroweaver.sf.net
Offline endolf

JGO Coder


Medals: 7
Exp: 15 years


Current project release date: sometime in 3003


« Reply #2 - Posted 2004-07-27 06:40:07 »

Hi
 Unsatisfied link errors should happen before that point if the dxjinput dll is missing, which makes me think the dll you have compiled is broken some how (the getNumButtons method is not there). The CVS version of the C code has it (just checked), so I can't see why it's not finding it.
 The only thing I can think of is that you have a really old version of the dll somewhere else on your system that java is finding, either in your jdk, your windows folders (I think it checks windows windows/system and windows/system32) so  search your whole machine for the dll. If there are no others then somehow you must have really old source for the c code, but newer java.

Hope that helps

Endolf

Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline mrdale

Junior Newbie




Java games rock!


« Reply #3 - Posted 2004-07-29 01:38:21 »

I am using the precompiled dll as I've been unable to untangle the #include spaghetti using either dx8 or 9.

All (and I've tried a bunch) of the -I's I've tried to get dinput.h to lead to a valid bunch of includes has failed.

Any clues on that front?

Thanks,
Dale.
Offline endolf

JGO Coder


Medals: 7
Exp: 15 years


Current project release date: sometime in 3003


« Reply #4 - Posted 2004-07-29 03:51:53 »

Hi
 The first time I built Jinput I just followed this instructions, got mingw, the dx bindings etc, and it worked. Are you using VC, or trying to use some other compiler?

It sounds like the binary dll you have is really old, i'd get a new one from https://games-binaries.dev.java.net/build/index.html and try again if I were you.

Cheers

Endolf

Pages: [1]
  ignore  |  Print  
 
 
You cannot reply to this message, because it is very, very old.

 

Add your game by posting it in the WIP section,
or publish it in Showcase.

The first screenshot will be displayed as a thumbnail.

Pippogeek (39 views)
2014-09-24 16:13:29

Pippogeek (30 views)
2014-09-24 16:12:22

Pippogeek (19 views)
2014-09-24 16:12:06

Grunnt (45 views)
2014-09-23 14:38:19

radar3301 (28 views)
2014-09-21 23:33:17

BurntPizza (63 views)
2014-09-21 02:42:18

BurntPizza (33 views)
2014-09-21 01:30:30

moogie (41 views)
2014-09-21 00:26:15

UprightPath (50 views)
2014-09-20 20:14:06

BurntPizza (54 views)
2014-09-19 03:14:18
List of Learning Resources
by Longor1996
2014-08-16 10:40:00

List of Learning Resources
by SilverTiger
2014-08-05 19:33:27

Resources for WIP games
by CogWheelz
2014-08-01 16:20:17

Resources for WIP games
by CogWheelz
2014-08-01 16:19:50

List of Learning Resources
by SilverTiger
2014-07-31 16:29:50

List of Learning Resources
by SilverTiger
2014-07-31 16:26:06

List of Learning Resources
by SilverTiger
2014-07-31 11:54:12

HotSpot Options
by dleskov
2014-07-08 01:59:08
java-gaming.org is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑gaming.org
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!