Hi !
Featured games (85)
games approved by the League of Dukes
Games in Showcase (612)
Games in Android Showcase (173)
games submitted by our members
Games in WIP (659)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  Eclipse crapped out on me??  (Read 1788 times)
0 Members and 1 Guest are viewing this topic.
Offline PlanetMongo

Senior Newbie

Follow the yellow line.  Don't EAT the yellow line

« Posted 2003-01-29 12:41:31 »

Hey guys.. I'm at work and was goofing off with Eclipse (it's installed, might as well learn it a bit more.. I currently use TextPad for most of my needs, but I'd like to learn Eclipse as I also do work in other languages here at work).  I was using a calculator tutorial I found for Eclipse (can't remember where.. on the eclipse site, I think) that I was working around to learn the basics of the IDE when something.. happened.   The app would compile fine, run fine, etc, except the app would  never close.  I could exit eclipse and the little window would remain (although it would contain the remant of whatever window was on top of it before).  I'd have to manually kill the process in task manager (win2k).  Anyway, I was trying to debug the program and something.. happened.  I don't know what.  I don't remember exactly, but something happened during that debug session.  So, now eclipse won't compile anything.  I tried creating a new project and importing an app I copied from Java Network Programming (compiles and runs fine from TextPad and the command line), and I get the following error when I try to compile:

Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

This looks like it can't find the VM or the classfiles, right?  Looking at what's it's calling, it's looking for the JRE at c:\Program Files\Java\j2re1.4.1_01\bin\javaw.exe and I've manually confirmed that the file is indeed there.  I've checked what setting I can find in window->Preferences (installed JRE, that's the only one.. I might try pointing it at the *other* JRE in the J2sdk1.4_1 directory (I think there's another there).

Anyway, I can still compile from the command line and in TextPad, as well as run stuff, so it makes me think there's a corrupt setting somewhere within Eclipse and I'm not really sure where to go from here to figure it out.

Any help would be appreciated.


If you were me, you'd be good lookin - six string samurai
Offline PlanetMongo

Senior Newbie

Follow the yellow line.  Don't EAT the yellow line

« Reply #1 - Posted 2003-01-29 12:53:56 »

Mkay, whilst dorking around some more, I got most of it fixed.. It seems that the "run" settings were still set to the old Calculator class stuff.  Changed it all over to PortScanner and it worked fine.  That's a bit.. retarded, if you ask me.  Open a new project and those settings should automatically change with the new project, or at least if it already does that, I need to figure out how to do it.. Tongue

If you were me, you'd be good lookin - six string samurai
Pages: [1]
  ignore  |  Print  
You cannot reply to this message, because it is very, very old.

Coldstream24 (7 views)
2015-09-03 00:41:28

Andrew_3ds (23 views)
2015-09-01 19:08:10

afikri (16 views)
2015-08-31 09:30:22

afikri (24 views)
2015-08-31 09:30:07

afikri (12 views)
2015-08-31 09:27:24

afikri (16 views)
2015-08-31 09:26:40

Roquen (23 views)
2015-08-29 11:30:54

GamerC4 (33 views)
2015-08-22 20:38:50

GamerC4 (29 views)
2015-08-22 20:37:18

GamerC4 (36 views)
2015-08-22 20:37:01
HotSpot Options
by Roquen
2015-08-29 11:33:11

Rendering resources
by Roquen
2015-08-17 12:42:29

Rendering resources
by Roquen
2015-08-17 09:36:56

Rendering resources
by Roquen
2015-08-13 07:40:51

Networking Resources
by Roquen
2015-08-13 07:40:43

List of Learning Resources
by gouessej
2015-07-09 11:29:36

How Do I Expand My Game?
by bashfrog
2015-06-14 11:34:43

List of Learning Resources
by PocketCrafter7
2015-05-31 05:37:30 is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!