Java-Gaming.org    
Featured games (79)
games approved by the League of Dukes
Games in Showcase (476)
Games in Android Showcase (106)
games submitted by our members
Games in WIP (531)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
 
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  [libgdx/gradle] Won't load gdx nightlies  (Read 454 times)
0 Members and 1 Guest are viewing this topic.
Offline atombrot

Senior Member


Medals: 9
Projects: 1



« Posted 2014-04-12 21:51:16 »

I'm trying to convert my libgdx project to the new gradle build format. I'm more or less done, but I'm running into a strange problem. I used gradle for the first time today, so it might be that I overlooked something obvious.

What I want is that my project uses the libgdx nightlies. When I check out the project on my build server and build it with gradle this seems to be working fine. But on my development machine it looks like gradle is using the stable releases instead of the nightlies.

Why I think that? I got some compile errors when building with gradle on my machine. I knew the places in the code, because I had changed them, when I updated my project from the stable 0.9.9 release to the nightlies. All of my changes had to be reverted...

One error I get is related with the scene2d actor SelectBox. I was using the class with a generic paramter, but now suddenly the compiler tells me, that select box does not has any generic types. I checked in the gdx github and it seems that the changes that introduced the generic type were added this february. I also checked some other cases with the same result, that the gdx lib does not match the code on github.

Here is my build.gradle file: http://pastebin.com/Etcb9T2G

What I have tried so far:
- Refresh references via eclipse
- Refresh references via command line
- Clear the gradle cache
- Clone the repository once more on both systems (dev machine / build server) and testing the gradle build with that version.

Everything yielded the same results and what's giving me most headaches is that the behavior is different on the server. I would appreciate the help, if somebody knows what I'm doing wrong.
Offline atombrot

Senior Member


Medals: 9
Projects: 1



« Reply #1 - Posted 2014-04-12 23:15:37 »

I think I have found the problem. I have tried to setup libgdx with maven some time ago, but I didn't manage to get it running, so (after I wasted some time) i decided to not use maven. From then I had an older snapshot release in my local maven repository. I wasn't aware of that. After deleting the badlogicgames folder in my local repo, gradle loaded the most recent nightlies.

Now this leads me to another question. How do I tell gradle to force update the snapshot releases? I tried the refresh references buttons in eclipse and in the command line, but it seems that this didn't really work. Any clues?
Pages: [1]
  ignore  |  Print  
 
 

 

Add your game by posting it in the WIP section,
or publish it in Showcase.

The first screenshot will be displayed as a thumbnail.

pw (13 views)
2014-07-24 01:59:36

Riven (13 views)
2014-07-23 21:16:32

Riven (13 views)
2014-07-23 21:07:15

Riven (14 views)
2014-07-23 20:56:16

ctomni231 (43 views)
2014-07-18 06:55:21

Zero Volt (39 views)
2014-07-17 23:47:54

danieldean (32 views)
2014-07-17 23:41:23

MustardPeter (35 views)
2014-07-16 23:30:00

Cero (50 views)
2014-07-16 00:42:17

Riven (50 views)
2014-07-14 18:02:53
HotSpot Options
by dleskov
2014-07-08 03:59:08

Java and Game Development Tutorials
by SwordsMiner
2014-06-14 00:58:24

Java and Game Development Tutorials
by SwordsMiner
2014-06-14 00:47:22

How do I start Java Game Development?
by ra4king
2014-05-17 11:13:37

HotSpot Options
by Roquen
2014-05-15 09:59:54

HotSpot Options
by Roquen
2014-05-06 15:03:10

Escape Analysis
by Roquen
2014-04-29 22:16:43

Experimental Toys
by Roquen
2014-04-28 13:24:22
java-gaming.org is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑gaming.org
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!