Hi !
Featured games (90)
games approved by the League of Dukes
Games in Showcase (686)
Games in Android Showcase (198)
games submitted by our members
Games in WIP (758)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  No I/O error in Eclipse  (Read 981 times)
0 Members and 1 Guest are viewing this topic.
Offline FlyingLow

Junior Newbie

« Posted 2014-02-27 16:26:08 »

Hi All,

I am a noob here and have been lurking on this forum for a while. I am currently working on a simple game but all of the sudden Eclipse doesn't want to run it anymore and just spits the "No I/O" message to the Console. I am pretty sure it is some simple setting somewhere but surprisingly Google did not return anything valuable. Instead of spending few hours fooling around with configuration and risking to make more damage I would appreciate any hints?
Offline Drenius
« Reply #1 - Posted 2014-02-27 16:33:44 »

Sounds like that a screenshot would be helpful.
Offline Gibbo3771

JGO Kernel

Medals: 128
Projects: 5
Exp: 1 year

Currently inactive on forums :(

« Reply #2 - Posted 2014-02-27 16:44:12 »

Sounds like that a screenshot would be helpful.

That or paste exactly what the console outputs.

"This code works flawlessly first time and exactly how I wanted it"
Said no programmer ever
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline Opiop
« Reply #3 - Posted 2014-02-27 17:31:57 »

This shouldn't happen ever, you should honestly try restarting your computer and downloading a new copy of Eclipse.
Offline FlyingLow

Junior Newbie

« Reply #4 - Posted 2014-02-28 00:39:16 »

Thanks guys. I unistalled Java completely, deleted eclipse, rebooted my laptop, downloaded and reinstalled java and same with eclipse. After importing workspace I tried to run the game again and got the same error. Below are screenshots that really don't say much.

Here is what I get in Eclipse console

And if I try to run it from command prompt:

I am playing around with pure Java2D, so no fancy libraries or paths to mess up things. BTW. I just tried to start a different project and it ran just fine, which leads to conclusion that something is wrong only with this particular project.... will dig deeper tonight. Again any pointer would be helpful.

Offline Jacob Pickens
« Reply #5 - Posted 2014-02-28 00:42:10 »

I have not a single clue to how this error is arising but i can tell you this, If its running other projects just re-start your project (Considering your not that far along). And if you are copy and paste the code.

Offline scanevaro
« Reply #6 - Posted 2014-02-28 01:04:09 »

debug your app from start to finish? or it wouldnt even run?
Offline FlyingLow

Junior Newbie

« Reply #7 - Posted 2014-02-28 01:21:58 »

No it doesn't even run in debug or regular mode.

I will try what Jacob Pickens suggested and make a new project tonight and copy&paste content and rebuild the whole thing.
Offline ricardo

Senior Devvie

Medals: 2
Projects: 3

« Reply #8 - Posted 2014-02-28 01:24:25 »

Clean your project first and see if it works.
Eclipse > Project > Clean.

EDIT: This is not one Eclipse error. This is a java error. Check if you have package.
Offline Longarmx
« Reply #9 - Posted 2014-02-28 04:36:38 »

Is this project using a different execution environment or target jdk?

Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline FlyingLow

Junior Newbie

« Reply #10 - Posted 2014-03-01 02:23:14 »

I am slowly getting there... I am able to run any project and also this one IF I remove multiplayer communication classes that use io. I installed both JRE and JDK and it seems neither has io packages included. Is that normal, I would assume that io should be part of any standard installation. So the next two questions are, how do I check if I have io and if not where do I get it?
Pages: [1]
  ignore  |  Print  
You cannot reply to this message, because it is very, very old.

roseslayer (488 views)
2016-08-06 11:43:29

roseslayer (446 views)
2016-08-06 09:43:11

xTheGamerCodes (520 views)
2016-08-04 15:40:59

xTheGamerCodes (513 views)
2016-08-04 15:40:24

orrenravid (861 views)
2016-07-16 03:57:23

theagentd (940 views)
2016-07-11 14:28:54

Hydroque (1034 views)
2016-07-06 05:56:57

Hydroque (1022 views)
2016-07-03 08:52:54

GrandCastle (838 views)
2016-07-01 09:13:47

GrandCastle (640 views)
2016-07-01 09:09:45
Rendering resources
by Roquen
2016-08-08 05:55:21

Rendering resources
by Roquen
2016-08-08 05:52:42

Rendering resources
by Roquen
2016-08-08 05:50:38

Rendering resources
by Roquen
2016-08-08 05:49:53

Rendering resources
by Roquen
2016-08-08 05:32:39

Making a Dynamic Plugin System
by Hydroque
2016-06-25 00:13:25

Java Data structures
by BinaryMonkL
2016-06-13 21:22:09

Java Data structures
by BinaryMonkL
2016-06-13 21:20:42 is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!