Hi !
Featured games (91)
games approved by the League of Dukes
Games in Showcase (804)
Games in Android Showcase (239)
games submitted by our members
Games in WIP (868)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  A Cup of Christmas Fear  (Read 16076 times)
0 Members and 1 Guest are viewing this topic.
Offline Opiop
« Posted 2014-02-16 04:56:43 »

A Cup of Christmas Fear is my Ludum Dare 28 game entry ported over to Android, and polished more! I started development ~2 days ago, and I wanted to get some sort of feedback early on. I know this thread is in the WIP section, I will be using this to post about my game. But right now I'm wondering if anyone would be so kind as to run the game on their phone and show/tell me what it looks like? I want to make sure that the game is re-sizing itself correctly to fit different resolutions as this is my first time experimenting with Android development!

Here's the download link:

Sorry I haven't said more, I'm sleepy and I need to rest!

Like I said above, if anyone would be so kind as to test it out, and report back about how it looks, I'd be very grateful! It really isn't at all complete yet, all you can do is move around a little.

Offline nerb
« Reply #1 - Posted 2014-02-16 05:47:25 »

G'day opiop,

I tried it on my Galaxy Nexus. No worries with scaling. The main menu was slightly un-responsive to touch at times, but the main game itself was fine.

Lifecycle events appear to be handled okay, but I think you might have an issue with OpenGL context loss. When I bail out using the back button, and then return to the game, all textures apart from the orange character have turned white. (From memory, exiting via the back button promotes context loss somehow; can't remember the details or logic behind it). There were no problems using the home button, or switching apps. You might need to double check you are recreating resources properly after you get the context back.


EDIT: That's if you're using OpenGL in some way, shape or form of course; I just noticed you haven't actually mentioned it, so I may have derped.  Cool
Offline Opiop
« Reply #2 - Posted 2014-02-16 14:47:34 »

Thank you nerb that's really helpful!

I'm using LibGDX because I want this process to go smooth, so I think I know what I'm doing wrong with the resuming! Its strange though, that never happens on any of my devices Sad

As for the main menu, can you tell me exactly what was wrong? Was the play button unresponsive or the volume button? The only button that actually does anything right now is the play button, so I'm just wondering what could have gone wrong!
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline nerb
« Reply #3 - Posted 2014-02-16 15:53:18 »

Both the sound and play buttons. For example, if I tap the sound button a few times in moderately quick succession, it doesn't always toggle (at an absolute rough guess, it only toggles about 70% of the time for me). The play button appears to do the same thing; I had to tap it twice just then. Speaking of the play button, it is not aligned in the vertical centre of the animated 'ribbon' on the main menu. The top of the button is aligned with the top of the ribbon. Not sure if that's intentional or not.

It doesn't surprise me you're not getting the error on your devices. That's one major frustration I've found with Android: you can test your app until the cows come home, but there is always at least one device that it won't play nicely with. Even worse, it seems to happen within similar devices too. I've tested my wallpaper on a number of Samsung S4's with no problems whatsoever. However I recently got a review stating that it causes a black screen on someone's S4... go figure... I'll hate myself for saying this, but that's one good thing Apple has going for it...

Offline Riven

« JGO Overlord »

Medals: 1371
Projects: 4
Exp: 16 years

Hand over your head.

« Reply #4 - Posted 2014-02-16 15:54:05 »

Screenshots in the first post are mandatory Pointing

Hi, appreciate more people! Σ ♥ = ¾
Learn how to award medals... and work your way up the social rankings!
Offline Opiop
« Reply #5 - Posted 2014-02-16 15:58:27 »

Screenshots in the first post are mandatory Pointing
Sorry, I'll do that now!

Nerb, that's strange! The volume button makes sense, I only toggle it when the player "releases" the touch on it, so maybe that's why it isn't working? The play button is very odd though, and again I've never had that issue on either of my Android devices! About the play button not being vertically aligned... could you upload a picture please? One of the biggest issues the game has right now is all the re-sizing because I've never done this before! Thanks for testing!

I just managed to also get the "bug" where the resources aren't reloading after hitting the back button, I'll be able to fix it now!
Offline nerb
« Reply #6 - Posted 2014-02-16 16:12:09 »

Err... My screenie looks very, very different to yours...  Huh
Offline Opiop
« Reply #7 - Posted 2014-02-16 16:17:16 »

Aghh what the hell Tongue Well this is strange... On the bottom of the screen, there should be an image of snow. On the top there is another image of the title. It seems that the two images are never loaded or never bound? The white spaces are where the images should be Sad
Offline nerb
« Reply #8 - Posted 2014-02-16 16:19:28 »

Appears so... Ignore all my waffle about the 'animated ribbon' then too.  persecutioncomplex
Offline Opiop
« Reply #9 - Posted 2014-02-16 16:45:33 »

I can't imagine what would cause this Sad I wonder if the APK was corrupted? Or the images weren't included in the APK for some reason? This is frustrating. This is how I draw my entire menu:

      batch.draw(snow, 0, 0);
      batch.draw(play.getButton(), play.getX(), play.getY());
      batch.draw(volume.getButton(), volume.getX(), volume.getY(), 96, 96);
      batch.draw(leaderboard.getButton(), leaderboard.getX(), leaderboard.getY(), 96, 96);
      batch.draw(title, / 2 - title.getWidth() / 2 + 5, - 250);
      font.draw(batch, "© Nishu Studios 2014", / 2 - 128, 50, 0, 0.5f, 0.5f);

I wonder if screen size has something to do with it. My tablet has no problems with it though...

Just read somewhere that some phones don't support none power of two textures no matter what. Both the title and the snow background aren't, could you please test it again when I change them over to power of two?
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline nerb
« Reply #10 - Posted 2014-02-16 16:55:50 »

No probs. It's getting late here so I'll check in the morning.
Offline Opiop
« Reply #11 - Posted 2014-02-16 17:02:27 »

Thanks Nerb, I just re-uploaded a new version that uses all power of two textures.
Offline Troubleshoots

JGO Knight

Medals: 36
Exp: 7-9 months

Damn maths.

« Reply #12 - Posted 2014-02-16 17:20:55 »

The screen size seems likely to be the issue. I can't recommend enough that you use Scene2D. It's really easy to use and once you get used to using skins, you can create a decent UI within 30 minutes. It provides table layout which is really useful for handling resizing.

Why are all OpenGL tutorials written in Brainf**k?
Offline Opiop
« Reply #13 - Posted 2014-02-16 17:23:01 »

I've used Scene2D before and I really don't like it, no offense to the developers. It is far to crazy to set up, and I can easily do what I need in < 10 minutes.
Offline nerb
« Reply #14 - Posted 2014-02-17 05:37:55 »

NPOT must have been the problem opiop. Main menu looks fine now. Out of interest, when the game starts, is there meant to be some kind of fade-in effect? The character is covered by a smallish white square, which gradually disappears. (Guessing it might be another NPOT issue).
Offline Opiop
« Reply #15 - Posted 2014-02-17 06:36:13 »

I actually do know what you're talking about, its supposed to be a count down. For some odd reason on my tablet (but not my phone) I get the same "white square" as you which leads me to believe I screwed up again somewhere with the power of two stuff. But I don't know, the menu worked on my tablet with the non power of two textures. The other odd thing is that I draw text on the main menu (the copyright stuff at the bottom) and it works fine on every device I've run the game on. I'll see what I can do!
Offline mikoch
« Reply #16 - Posted 2014-02-17 08:51:22 »

Issues I've found:
- Buttons on main screen seems unresponsive. It looks like I have to touch it exactly in the center. This is especially visible with a "sound on/off" button that is very small. I am able to turn it on/off but I have to be very precise. (scaling issues?)
- I have the same problem as nerb - exiting the app with "back" button and starting again causes all textures except avatar to be white
- After I press "play" button whole level is rendered correctly but for the first 2 seconds white rectangle is rendered in the center of the screen and is shrinking until it disappears.

Apart from that I can control avatar correctly.

tested on Nexus 7.

Offline Opiop
« Reply #17 - Posted 2014-02-17 12:26:05 »

Ok, thanks for reporting!

The white texture in the middle of the player should be a count down, but I think I know how to fix that.

The back button issue. That's annoying because I swear I fixed it. I had the same issue with my Galaxy S3, but I reworked it so the textures would be recreated when the game resumes and now it works fine on my phone.

The menu is also frustrating considering I've never had that issue... Just scaling issues I guess.

Thank you!

Just realized the menu will only work correctly when your screen ratio is 16:9. The Nexus 7 is 8:5. Looks like I have more work to do!
Offline Opiop
« Reply #18 - Posted 2014-02-17 13:27:57 »

New version that should fix all the issues with hitting back and then resuming! Also, collision detection and some primitive response Smiley Still need to make the player slide along walls. Fixed an issue where there was a white rectangle rendered on screen in game, that should have been text!
Offline nerb
« Reply #19 - Posted 2014-02-17 13:41:37 »

New version that should fix all the issues with hitting back and then resuming!

Yup. All good!

I did get an "Xmas Fear has stopped working" on first launch after updating, but I couldn't replicate it. I'll let you know if it happens again.
Offline Opiop
« Reply #20 - Posted 2014-02-17 14:27:20 »

Sorry for the frequent posts!

Nerb, thank you as always!

I think I fixed the issues with the main menu, it should now scale correctly! (Hopefully Wink ). If anyone has an Android phone/tablet who's screen ratio isn't 16:9 (because I know it scales correctly on 16:9) could test it out, it would be much appreciated! I tried running it under the Nexus 7 in the Android Virtual Device emulator, and it seemed to work, but I still want it tested on actual hardware!
Offline mikoch
« Reply #21 - Posted 2014-02-17 19:11:21 »

I tried running it under the Nexus 7 in the Android Virtual Device emulator, and it seemed to work, but I still want it tested on actual hardware!

I would retest on my nexus 7 but dropbox link you provided stopped working. I get 404 - (maybe it's dropbox servers issue)

Offline Opiop
« Reply #22 - Posted 2014-02-17 19:28:39 »

Sorry Mikoch, I forgot to update the link! It should be good now.
Offline mikoch
« Reply #23 - Posted 2014-02-17 19:59:49 »

I've retested and:
- countdown 3,2,1 is correctly visible now
- exiting app and entering again works correctly (all textures are visible)

only buttons are still not very responsive, have to be touch in the center

Offline Opiop
« Reply #24 - Posted 2014-02-18 00:47:10 »

Huh, while that is an issue I haven't been able to reproduce it at all so there's really no way I can fix it :/ I'll try, but I have no idea what I could be doing wrong!
Offline LiquidNitrogen
« Reply #25 - Posted 2014-03-06 04:40:09 »

just downloaded and setup the android sdk, your program runs fine on the emulator. any progress with the project?
Pages: [1]
  ignore  |  Print  

Riven (585 views)
2019-09-04 15:33:17

hadezbladez (5522 views)
2018-11-16 13:46:03

hadezbladez (2405 views)
2018-11-16 13:41:33

hadezbladez (5784 views)
2018-11-16 13:35:35

hadezbladez (1227 views)
2018-11-16 13:32:03

EgonOlsen (4666 views)
2018-06-10 19:43:48

EgonOlsen (5685 views)
2018-06-10 19:43:44

EgonOlsen (3199 views)
2018-06-10 19:43:20

DesertCoockie (4099 views)
2018-05-13 18:23:11

nelsongames (5117 views)
2018-04-24 18:15:36
A NON-ideal modular configuration for Eclipse with JavaFX
by philfrei
2019-12-19 19:35:12

Java Gaming Resources
by philfrei
2019-05-14 16:15:13

Deployment and Packaging
by philfrei
2019-05-08 15:15:36

Deployment and Packaging
by philfrei
2019-05-08 15:13:34

Deployment and Packaging
by philfrei
2019-02-17 20:25:53

Deployment and Packaging
by mudlee
2018-08-22 18:09:50

Java Gaming Resources
by gouessej
2018-08-22 08:19:41

Deployment and Packaging
by gouessej
2018-08-22 08:04:08 is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!