Hi !
Featured games (90)
games approved by the League of Dukes
Games in Showcase (789)
Games in Android Showcase (234)
games submitted by our members
Games in WIP (864)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  Freja and the sequel  (Read 10261 times)
0 Members and 1 Guest are viewing this topic.
Offline Jens_S
« Posted 2014-02-04 19:43:59 »

Hi everyone!

This is my new game "Freja and the sequel". It's an old-school point and click-adventure (or maybe a new-school interactive story?).

It's using (the very nice) libGdx, which made it easy to make one version for Android, and one desktop version (for Linux, Windows och Mac).

The Android version can be downloaded from here:

And the desktop version can be downloaded from here:

I would be very happy for all kinds of feedback. The game is more or less finished, so I will not make any major changes, but will take the feedback with me to future projects! Smiley

And here is a screenshot:
Offline wessles
« Reply #1 - Posted 2014-02-05 02:28:56 »

Nice job man! Did not get all the way through, but it is a nice game!

- I am always a fan of dry, brisk conversations; like in Hitchhikers Guide. It is just back and forth of stating the obvious thing, with no impatience.
- I like the art style too, although some of it looks like you did a bad feather select and had white space left-over... Like to blue man.

I look forward to Freja and the PREQUEL!
-wes  Smiley
Offline Drenius
« Reply #2 - Posted 2014-02-05 19:49:08 »

This is really interesting!
A story where I was really thinking 'what drugs did he take?' again and again...
But very good!
Lost interest when walking out of the childhood bedroom at the left side and got moved back to the point where you have to go to the managers office to get the job. It was not even possible to redo the story because the items in the cave were taken, but not in the inventory...
Is it a bug?
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline Jens_S
« Reply #3 - Posted 2014-02-05 21:40:48 »


This is not supposed to happen, and sound very much like a bug actually. Thanks a lot for finding it!

However, I cannot reproduce this... Were you able leave the second childhood room (the one with the mother) to the left? Or did the bug occur after you left the childhood trough the painting?

Did you play the Android version or the desktop-version?

Thanks in advance for all kinds of info on this! I really like to fix this asap. Smiley
Offline Jens_S
« Reply #4 - Posted 2014-02-05 21:43:44 »

Hi again Drenius!

I found the bug, and it's fixed now. I'll upload a new version of the game tomorrow.

Thanks for finding an reporting the bug!
Offline Drenius
« Reply #5 - Posted 2014-02-05 21:46:23 »

Win7 Desktop. The first bedroom and I was able to leave it to the left as if there is another room next to it.
Oh and sometimes in the first ... levels ... the mouse cursor disappeared, I had to restart the game...
Offline Jens_S
« Reply #6 - Posted 2014-02-06 17:35:41 »

Hi again!

Now is the new version uploaded to and to Google Play.
There was an invisible door that you could go into, who took one back to the office ... Now it removed.

Strange that no one has seen this before, but some bugs are good at hiding as we all know. Thank you for finding it!

I've also added a few new jokes, and fixed one or two spelling errors.

I can not reproduce the error with the mouse pointer on my linux machine, but I'll look into it. Thanks!
Offline Tracers

Senior Newbie

Projects: 1

« Reply #7 - Posted 2014-02-07 08:53:05 »

I like the game, never played something like this before!
No issues while playing on my nexus 7, some textures do look really small at this size however.
I  did get a crash when I tried exiting back to the main menu!
otherwise good game with good music!
Offline Jens_S
« Reply #8 - Posted 2014-02-07 18:54:21 »

Hi Tracers!

Nice to hear that you liked the game!

I have not run into any crashes when I've tested on the Nexus 7, so I'm really interested in your crash. Smiley Do you always get a crash when exiting to the main menu, or is it just sometimes? Does it crash under some special circumstances? And did the autosave work properly after the crash, or did it screw up in some way?

Thanks in advance!
Offline Tracers

Senior Newbie

Projects: 1

« Reply #9 - Posted 2014-02-07 19:33:32 »

I did loose all of my progress!
I tried again and everytime when i click the top left button to go back to main menu it crashes and my progress isn't stored!
I just sent in a report so you can see crash data!
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline Jens_S
« Reply #10 - Posted 2014-02-07 19:55:41 »

Hi Tracers!

Thanks a lot for your error report! I'm pretty sure I have fixed the issue now, and am uploading a new version right now. Phew. Smiley
Offline Jens_S
« Reply #11 - Posted 2014-11-13 16:35:44 »


Old topic, and old game, but this game is now finally out on iOS. You can download it from:

I've used RoboVM to port the game to iOS, so the main engine source code is still Java. There were a few hiccups on the way, but porting the game was fairly straightforward and now the game runs well on iOS. All of the game logic is written in a custom domain specific language, and executed by a small interpreter I wrote in Java. RoboVM makes it possible to run my own interpreter on iOS, which makes it possible to run my domain specific language on iPhone/iPad. Impressive!

I can really recommend RoboVM - fantastic piece of software!

Best regards
Pages: [1]
  ignore  |  Print  

Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!