Hi !
Featured games (85)
games approved by the League of Dukes
Games in Showcase (636)
Games in Android Showcase (178)
games submitted by our members
Games in WIP (685)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  DX 9 question  (Read 1929 times)
0 Members and 1 Guest are viewing this topic.
Offline TheAnalogKid

JGO Coder

Projects: 2

« Posted 2003-01-02 17:51:38 »


One question: Should I upgrade to DX 9 until a new j2se release supports it?


Offline elias

Senior Devvie

« Reply #1 - Posted 2003-01-02 19:32:43 »

erhm, not sure what you meant by waiting to upgrade... but installing dx9 shuldn't matter to j2se, as all earlier dx interfaces will still be supported. Just like older games (almost) always work with newer dx version.


Offline Abuse

JGO Ninja

Medals: 42

falling into the abyss of reality

« Reply #2 - Posted 2003-01-02 22:43:39 »

From a users perspective, I havn't noticed any difference since I installed dx9.
Though im sure all the d3d coders are rubbing their hands together at all the new 3d features Cool

Make Elite IV:Dangerous happen! Pledge your backing at KICKSTARTER here!
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline Themroc

Junior Devvie

« Reply #3 - Posted 2003-01-05 09:46:00 »

I read that Dx9 is not considered stable (I guess I read it on or so).  So at least I will wait a few more weeks. New versions of DirectX usually don't improve old software much, although MS always claims speed upgrades etc.

Which is the minimum version of DirectX required by j2se anyway?
Offline elias

Senior Devvie

« Reply #4 - Posted 2003-01-05 10:14:15 »


Which is the minimum version of DirectX required by j2se anyway?

Don't think there is a minimum version - j2se 2d code has fallbacks to non-directx code. But to use directdraw, it probably doesn't require a directx that new - directx 3 , afaik, is the latest directx on winnt 4.

- elias

Offline trembovetski

Senior Devvie

If only I knew what I'm talking about!

« Reply #5 - Posted 2003-01-08 03:37:44 »

Starting with jdk1.4.1 we use some of  Direct3D functionality (which caused a lot of fun for the ATI users, unfortunately), which first appeared in DirectX5.

So yes, it'll still work on DX3 (on WindowsNT, for example), but with using DirectDraw only (so no D3D accelerated lines to the back-buffer, for example).

I doubt that you'd get any benefit when running java apps if you upgrade to DX9, though.
Pages: [1]
  ignore  |  Print  
You cannot reply to this message, because it is very, very old.

Dwinin (59 views)
2015-11-07 13:29:08

Rems19 (72 views)
2015-10-31 01:36:56

Rems19 (64 views)
2015-10-31 01:32:37

williamwoles (102 views)
2015-10-23 10:42:59

williamwoles (88 views)
2015-10-23 10:42:45

Jervac_ (102 views)
2015-10-18 23:29:12

DarkCart (128 views)
2015-10-16 00:58:11

KaiHH (112 views)
2015-10-11 14:10:14

KaiHH (150 views)
2015-10-11 13:26:18

BurntPizza (164 views)
2015-10-08 03:11:46
Rendering resources
by Roquen
2015-11-13 14:37:59

Rendering resources
by Roquen
2015-11-13 14:36:58

Math: Resources
by Roquen
2015-10-22 07:46:10

Networking Resources
by Roquen
2015-10-16 07:12:30

Rendering resources
by Roquen
2015-10-15 07:40:48

Math: Inequality properties
by Roquen
2015-10-01 13:30:46

Math: Inequality properties
by Roquen
2015-09-30 16:06:05

HotSpot Options
by Roquen
2015-08-29 11:33:11 is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!