Hi !
Featured games (90)
games approved by the League of Dukes
Games in Showcase (739)
Games in Android Showcase (224)
games submitted by our members
Games in WIP (820)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  UDP: Port unreachable  (Read 4596 times)
0 Members and 1 Guest are viewing this topic.
Offline darcone

Junior Devvie

Size matters

« Posted 2003-11-24 18:31:09 »

Hey again...
So I finally made my game work with UDP, from localhost to localhost =/
When I try to play over a network, I get ICMP messages back telling me that the port is unreachable (tried it with ethereal).

I start the UDP server on port 27901, and send UDP packets there... I tried it with port 9001 as well.

Anyone got a idea?
Offline endolf

JGO Coder

Medals: 7
Exp: 15 years

Current project release date: sometime in 3003

« Reply #1 - Posted 2003-11-24 18:56:56 »

 What interface are you listening on at the receiving end(s) ?, if you are on linux, can you use nc to conenct to that udp port?, can you ping the machine, are they both on the local lan, or is one outside it?



Offline darcone

Junior Devvie

Size matters

« Reply #2 - Posted 2003-11-24 20:26:09 »

I tried with a test program to open a socket and send data to it and it worked from localhost to localhost... How would I try to send/get data with nc ?

Perhaps I am binding the socket wrong? Maybe java is doing some security checks that only allows localhost to send data to it?

channel =;
                ((DatagramChannel)channel).socket().bind(inetAddress = new InetSocketAddress("localhost", port));
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline darcone

Junior Devvie

Size matters

« Reply #3 - Posted 2003-11-24 20:52:58 »

yeah that was it, I removed the "localhost" and now it works Wink thanks
Offline elias

Senior Devvie

« Reply #4 - Posted 2003-11-25 03:58:08 »

I'm no UDP expert here, but it looks like you tried to bind the listening socket to the localhost interface. No packet can reach that interface except those coming from the same machine. Removing it made your socket bind to all interfaces available on your system, that is, the local interface and any adapter interfaces. In short, I don't think it was a security measure :-)

- elias

Pages: [1]
  ignore  |  Print  
You cannot reply to this message, because it is very, very old.

Ecumene (55 views)
2017-09-30 02:57:34

theagentd (78 views)
2017-09-26 18:23:31

cybrmynd (186 views)
2017-08-02 12:28:51

cybrmynd (184 views)
2017-08-02 12:19:43

cybrmynd (191 views)
2017-08-02 12:18:09

Sralse (201 views)
2017-07-25 17:13:48

Archive (757 views)
2017-04-27 17:45:51

buddyBro (891 views)
2017-04-05 03:38:00

CopyableCougar4 (1440 views)
2017-03-24 15:39:42

theagentd (1323 views)
2017-03-24 15:32:08
List of Learning Resources
by elect
2017-03-13 14:05:44

List of Learning Resources
by elect
2017-03-13 14:04:45

SF/X Libraries
by philfrei
2017-03-02 08:45:19

SF/X Libraries
by philfrei
2017-03-02 08:44:05

SF/X Libraries
by SkyAphid
2017-03-02 06:38:56

SF/X Libraries
by SkyAphid
2017-03-02 06:38:32

SF/X Libraries
by SkyAphid
2017-03-02 06:38:05

SF/X Libraries
by SkyAphid
2017-03-02 06:37:51 is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!