Hi !
Featured games (90)
games approved by the League of Dukes
Games in Showcase (781)
Games in Android Showcase (233)
games submitted by our members
Games in WIP (857)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  Eclipse Acting Up  (Read 7796 times)
0 Members and 1 Guest are viewing this topic.
Offline Longarmx
« Posted 2012-05-19 16:35:10 »

Recently, I switched from a Mac to a PC. I thought that I set up Eclipse correctly but every time I exit out of a JFrame, Eclipse spits out an error at me.

Unable to open SCSI controller 0:[\] , error code: 0x5
Unable to open SCSI controller 1:[\] , error code: 0x5

I've tested this on other projects that use a JFrame, but it still does the same thing. This is my code if it is relevant to this problem:

package src.longarmx.rts;

import java.awt.Dimension;

import javax.swing.JFrame;

public class Frame {
   public static int width = 800;
   public static int height = 600;

   public static void main(String[] args) {

      Dimension size = new Dimension(width, height);
      JFrame frame = new JFrame();
      frame.setTitle("RTS Game");
      Screen s = new Screen(frame);



I don't know if it helps, but I am running a 64-bit eclipse and I haven't messed with the Java Path variable at all.



Offline matheus23

JGO Kernel

Medals: 138
Projects: 3

You think about my Avatar right now!

« Reply #1 - Posted 2012-05-19 16:42:17 »

This is what I got on googleing:

Some comment at the botton says, there would exist a problem with the hard disk?!?

One thing though:
It sounds strange as I never had to do this before any other Java2D JFrame projects, but with my last project I had an issue with setVisible(true);
It helped to write it like that:
SwingUtilities.invokeLater(new Runnable() {
    public void run() {

But thats kind of off-topic. It won't fix it, I'm sure.

Also, I tested it, and it works for me...
I had to remove line 25 and 26 though... Wink

See my:
    My development Blog:     | Or look at my RPG | Or simply my coding
http://matheusdev.tumblr.comRuins of Revenge  |      On Github
Offline loom_weaver

JGO Coder

Medals: 17

« Reply #2 - Posted 2012-05-19 17:16:40 »

Very odd... might be an error message coming from the OS.

I'd back up your files NOW!
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline Longarmx
« Reply #3 - Posted 2012-05-19 17:34:10 »

Are you guys saying that something is wrong with the operating system or is it a virus possibly? This is a week old computer so I don't think that anything could have gone wrong yet. This error came up 2 days after the computer arrived and eclipse was one of the first things I ran.

Offline davedes
« Reply #4 - Posted 2012-05-19 17:43:49 »

Is the problem only in Eclipse? Or does it occur from command-line compilation too?

My best guess is that Eclipse or a plugin is trying to find out the disk's serial number for some reason, and it isn't able to because the of admin rights. Try running Eclipse with full administrative rights (or disable the admin control) to see if that changes anything.

Also try updating Eclipse to the latest version, if you haven't already.

Offline Longarmx
« Reply #5 - Posted 2012-05-19 18:09:04 »

@davedes I tested it and Eclipse is the only problem.

I am the admin so I have all of the administrative rights.

Eclipse is the updated to the current version.

Offline UprightPath
« Reply #6 - Posted 2012-05-19 18:12:16 »

Just because you're on an administrator account does not mean that the program is being "Run as Administrator". Right click the .exe and select that option, then tell us.

Also, you said that it's a new computer? What type of AV does it have? Because I've had some lovely AV issues where it blocked operations on programs, went fun with temporary files and the like.

Offline ra4king

JGO Kernel

Medals: 508
Projects: 3
Exp: 5 years

I'm the King!

« Reply #7 - Posted 2012-05-19 19:06:19 »

Concerning AV: Microsoft Security Essentials should be the only AV everyone uses Smiley

Offline Longarmx
« Reply #8 - Posted 2012-05-19 20:52:35 »

Right now I am using norton antivirus and everything has been confirmed safe except for one program:  The issue was happening before I downloaded this though and I would trust that program. Currently I am backing up all of the files. Should I then delete everything from the computer and then re-install the os?

Offline UprightPath
« Reply #9 - Posted 2012-05-19 21:01:33 »

See if you can make your AV ignore the files that you're trying to run, then try to run it.

Always try a bunch of other things first. Unless you don't have a lot of stuff on your computer and don't mind a factory restore.

Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline sproingie

JGO Kernel

Medals: 202

« Reply #10 - Posted 2012-05-20 06:13:49 »

Does it give you this error when you package the app and run it outside of Eclipse?  

I find a lot of Eclipse problems are solved by reinstalling Eclipse.  Eclipse suffers from bit rot like nothing else.

Offline Longarmx
« Reply #11 - Posted 2012-05-21 02:11:32 »

@sproingie I have ran this program outside of eclipse but where do you get the errors if there are any? Also, I re-downloaded eclipse and I still get the same error.

Offline princec

« JGO Spiffy Duke »

Medals: 1064
Projects: 3
Exp: 20 years

Eh? Who? What? ... Me?

« Reply #12 - Posted 2012-05-21 08:51:48 »

The error message looks more driver related than Eclipse related. Just a hunch. Eclipse (or indeed Java) cannot open SCSI controllers.

Cas Smiley

Pages: [1]
  ignore  |  Print  

hadezbladez (1177 views)
2018-11-16 13:46:03

hadezbladez (531 views)
2018-11-16 13:41:33

hadezbladez (1190 views)
2018-11-16 13:35:35

hadezbladez (274 views)
2018-11-16 13:32:03

EgonOlsen (2571 views)
2018-06-10 19:43:48

EgonOlsen (2790 views)
2018-06-10 19:43:44

EgonOlsen (1566 views)
2018-06-10 19:43:20

DesertCoockie (2271 views)
2018-05-13 18:23:11

nelsongames (2124 views)
2018-04-24 18:15:36

nelsongames (2817 views)
2018-04-24 18:14:32
Deployment and Packaging
by philfrei
2019-02-17 20:25:53

Deployment and Packaging
by mudlee
2018-08-22 18:09:50

Java Gaming Resources
by gouessej
2018-08-22 08:19:41

Deployment and Packaging
by gouessej
2018-08-22 08:04:08

Deployment and Packaging
by gouessej
2018-08-22 08:03:45

Deployment and Packaging
by philfrei
2018-08-20 02:33:38

Deployment and Packaging
by philfrei
2018-08-20 02:29:55

Deployment and Packaging
by philfrei
2018-08-19 23:56:20 is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!