If you think this is bad you should see the code from when I started, for some odd reason when I am writing code variable names just don't come to me. but it is all in the works, getting better every day...
This is non-relevant to the original question, but one good way to write good variable names is to use mathematical names for them.
pointX / posX //Point is a point in the coordinate grid, therefore a coordinate.
pointY / posY
velX //velocity is from what i have understood the same thing as speed
accX //acceleration is change in velocity if i remember correctly
That's my way of naming my variables