Java-Gaming.org    
Featured games (91)
games approved by the League of Dukes
Games in Showcase (577)
games submitted by our members
Games in WIP (498)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
 
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  different screen resolutions and Android 1.5  (Read 1655 times)
0 Members and 1 Guest are viewing this topic.
Offline teletubo
« League of Dukes »

JGO Ninja


Medals: 48
Projects: 6
Exp: 8 years



« Posted 2010-02-23 18:52:28 »

I am trying to make my new game compatible from android 1.5 on, and also make it compatible with different screen resolutions, like the droid screen. 
However, I can't find a way to make it both "the same time" .
The conclusion I found was :
If I compile it for 1.5 compatibility, it will not detected different screen resolutions (at least that is what happened in the emulator).
If I compile it for 1.6 it will resize accordingly to the screen resolution, but then I'll obviously not be able to run it on 1.5 .

Are my conclusions correct ? If not, how can I make it detect and run with different screen resolutions and still run on 1.5 ?
I wish to make it run 1.5 cause there are still a lot of devices with it (mine included) and I dont want to "lose" that players.



thanks .

Offline noblemaster

JGO Ninja


Medals: 19
Projects: 9


Age of Conquest makes your day!


« Reply #1 - Posted 2010-02-23 20:26:12 »

You can set the min SDK to 1.5 and the target SDK to 1.6 (Android Manifest). That did the trick for me!

Offline strategy

Junior Member


Projects: 1



« Reply #2 - Posted 2010-02-23 22:56:35 »

Yep. Though you do need to ensure that various screen resolutions are supported by your resources. There is one nasty bug where if you have a default  "drawable" and a "drawable-hdpi" catalog, it will actually use the hdpi graphics. Just make sure you have -mdpi and -hdpi and it should work fine.

I'll be a happy camper when 1.5 gets phased out. :-/

Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline teletubo
« League of Dukes »

JGO Ninja


Medals: 48
Projects: 6
Exp: 8 years



« Reply #3 - Posted 2010-02-23 23:35:45 »

You can set the min SDK to 1.5 and the target SDK to 1.6 (Android Manifest). That did the trick for me!

yep, that did the trick !
Thanks !

Pages: [1]
  ignore  |  Print  
 
 
You cannot reply to this message, because it is very, very old.

 

Add your game by posting it in the WIP section,
or publish it in Showcase.

The first screenshot will be displayed as a thumbnail.

xsi3rr4x (23 views)
2014-04-15 18:08:23

BurntPizza (18 views)
2014-04-15 03:46:01

UprightPath (32 views)
2014-04-14 17:39:50

UprightPath (16 views)
2014-04-14 17:35:47

Porlus (32 views)
2014-04-14 15:48:38

tom_mai78101 (58 views)
2014-04-10 04:04:31

BurntPizza (116 views)
2014-04-08 23:06:04

tom_mai78101 (216 views)
2014-04-05 13:34:39

trollwarrior1 (183 views)
2014-04-04 12:06:45

CJLetsGame (190 views)
2014-04-01 02:16:10
List of Learning Resources
by Longarmx
2014-04-08 03:14:44

Good Examples
by matheus23
2014-04-05 13:51:37

Good Examples
by Grunnt
2014-04-03 15:48:46

Good Examples
by Grunnt
2014-04-03 15:48:37

Good Examples
by matheus23
2014-04-01 18:40:51

Good Examples
by matheus23
2014-04-01 18:40:34

Anonymous/Local/Inner class gotchas
by Roquen
2014-03-11 15:22:30

Anonymous/Local/Inner class gotchas
by Roquen
2014-03-11 15:05:20
java-gaming.org is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑gaming.org
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!