Java-Gaming.org Hi !
Featured games (83)
games approved by the League of Dukes
Games in Showcase (539)
Games in Android Showcase (132)
games submitted by our members
Games in WIP (603)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
 
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  Loading resources from multiple JARs  (Read 1936 times)
0 Members and 1 Guest are viewing this topic.
Offline Jesse_Attard

Senior Newbie





« Posted 2008-09-28 13:48:06 »

Cross-posting with sun forums since I'm getting no response, maybe you guys can help with this issue as I'm sure other games have needed this behaviour.

I am attempting to load various resources (images, sounds, files) from a separate JAR from my source class. I have two jars:

source.jar <- contains all my class files
resources.jar <- contains all my images/sounds.

If I do not split these into two jars, everything works as expected. I am using the following HTML tag:

<applet code=Main.MyClass.class ARCHIVE="source.jar, resources.jar" width="800" height="600">

And the following resource loading code with and without the slash '/':

applet.getClass().getResourceAsStream("images/temp/test.png") <- Does not work, Returns null.
applet.getClass().getResourceAsStream("/images/temp/test.png") <- Works when I have everything in the same JAR, but not when they are separate. Returns null.

I am splitting up the JARs so the large resources can download separately via JAR Indexing. But, I cannot access this test image with or without indexing when the JARs are separated.  Directory structure is:

source.jar:
Main/MyClass.class
Lib/OtherClass.class
Data/SomeData.bin
^ all load fine

resources.jar:
images/temp/test.png
sounds/mysound.ogg
^ cannot access these =(

Am I missing something here?

Jesse
Offline Eli Delventhal

JGO Kernel


Medals: 42
Projects: 11
Exp: 10 years


Game Engineer


« Reply #1 - Posted 2008-09-28 18:21:12 »

I'm not sure about applets, but I've used multiple JARs in Java Webstart applications on several occasions. In that case, you just need to list both as resources in your JNLP file, and then directories are preserved.

As far as I know you don't want that leading slash in there, because doing that tells it to go to the root directory and then look from there, rather than the current directory. Have you tried adding on a "user.dir" call?

See my work:
OTC Software
Offline Jesse_Attard

Senior Newbie





« Reply #2 - Posted 2008-09-29 13:05:45 »

From what I've read, having no leading slash prepends the class's package name converting all .'s to /'s.  I suppose this is useful when you want to load resources that are in subdirectories from your class files, but I have my resources in a separate directory.  I tried having no slash and this fails whether I have the files together or in separate JARs.

I haven't tried applet.getCodeBase() + "images/temp/test.png" (is that what you mean by user.dir?) ... maybe I'll give that a shot.. but I don't see how it knows then to open up a JAR and not some resource sitting on a server.

And as I'm sure you know there are no JNLP files for applets =(. Everything I've read seems to imply that getResourceAsStream() should search the full classpath, including both JARs, to look for resources... so I must be doing something wrong here.

Jesse
Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline cylab

JGO Ninja


Medals: 55



« Reply #3 - Posted 2008-09-29 19:52:50 »

<applet code=Main.MyClass.class ARCHIVE="source.jar, resources.jar" width="800" height="600">

Tried to remove the space from the archive attribute?
1  
<applet code="Main.MyClass.class" ARCHIVE="source.jar,resources.jar" width="800" height="600">

Mathias - I Know What [you] Did Last Summer!
Offline Jesse_Attard

Senior Newbie





« Reply #4 - Posted 2008-10-07 01:06:15 »

Sorry it took so long to reply. I just tried with no space in the ARCHIVE tag, and it made no difference.

No one has deployed a game through an applet like this? =(
Offline Jesse_Attard

Senior Newbie





« Reply #5 - Posted 2008-10-07 01:25:13 »

Umm so I named it resources.Jar with a capital J.  Wow I'm bad.  Umm... yeah. embarassed
Offline noblemaster

« JGO Spiffy Duke »


Medals: 20
Projects: 10


Age of Conquest makes your day!


« Reply #6 - Posted 2008-10-07 01:33:40 »

I use multiple jars. The following always works for me:
1  
<object>.getClass().getClassLoader().getResourceAsStream(path);


path is the relative path e.g. "image/interface/button.gif"...

Please note the getClassLoader() statement that I am using. Mabye omitting the statement prevents you from getting it to work?

Pages: [1]
  ignore  |  Print  
 
 
You cannot reply to this message, because it is very, very old.

 

Add your game by posting it in the WIP section,
or publish it in Showcase.

The first screenshot will be displayed as a thumbnail.

rwatson462 (30 views)
2014-12-15 09:26:44

Mr.CodeIt (23 views)
2014-12-14 19:50:38

BurntPizza (50 views)
2014-12-09 22:41:13

BurntPizza (84 views)
2014-12-08 04:46:31

JscottyBieshaar (45 views)
2014-12-05 12:39:02

SHC (59 views)
2014-12-03 16:27:13

CopyableCougar4 (57 views)
2014-11-29 21:32:03

toopeicgaming1999 (123 views)
2014-11-26 15:22:04

toopeicgaming1999 (114 views)
2014-11-26 15:20:36

toopeicgaming1999 (32 views)
2014-11-26 15:20:08
Resources for WIP games
by kpars
2014-12-18 10:26:14

Understanding relations between setOrigin, setScale and setPosition in libGdx
by mbabuskov
2014-10-09 22:35:00

Definite guide to supporting multiple device resolutions on Android (2014)
by mbabuskov
2014-10-02 22:36:02

List of Learning Resources
by Longor1996
2014-08-16 10:40:00

List of Learning Resources
by SilverTiger
2014-08-05 19:33:27

Resources for WIP games
by CogWheelz
2014-08-01 16:20:17

Resources for WIP games
by CogWheelz
2014-08-01 16:19:50

List of Learning Resources
by SilverTiger
2014-07-31 16:29:50
java-gaming.org is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑gaming.org
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!