Hi !
Featured games (84)
games approved by the League of Dukes
Games in Showcase (601)
Games in Android Showcase (171)
games submitted by our members
Games in WIP (649)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  Building/Downloading for Mac OSX  (Read 2864 times)
0 Members and 1 Guest are viewing this topic.
Offline Lareon

Senior Newbie

I program for fun... Isn't that weird?!?

« Posted 2007-02-24 17:49:15 »


I downloaded the nightly build for JInput, but it doesn't have a MacOS X native executable library.  It lists linux and DirectX in the plugins directory, but there aren't plugins fro those systems either.

I tried compiling from the source (all of the nightly-build downloads, including source, are dated back in 2005 on the website: ), but that returned the same error that was shown here: even though it's almost 2 years later.

Have I completely missed something obvious here?

-- Scott
Offline Lareon

Senior Newbie

I program for fun... Isn't that weird?!?

« Reply #1 - Posted 2007-02-25 07:07:46 »

Okay, here's something better:

I got a login to the website so I downloaded all of the project directories and run 'ant' to build them.  Jutils built fine; Jinput bombed out pretty early until I copied 'jutils.jar' into my system classpath, but that's fine.  Now it bombs out much later into the dynamic lib compilation with the following error message:

    [apply] gcc-3.3: installation problem, cannot exec `cc1': No such file or directory

/Users/scott/java/games-core/jinput/build.xml:87: The following error occurred while executing this line:
/Users/scott/java/games-core/jinput/build.xml:63: The following error occurred while executing this line:
/Users/scott/java/games-core/jinput/plugins/OSX/build.xml:75: The following error occurred while executing this line:
/Users/scott/java/games-core/jinput/plugins/OSX/src/native/build.xml:54: The following error occurred while executing this line:
/Users/scott/java/games-core/jinput/plugins/OSX/src/native/build.xml:19: apply returned: 1

I've posted the whole output here, in case anyone's interested:

I can see clearly the error, though I have little idea what would cause that.  I can't even ind any file which mentions 'cc1' at all... -.-;;  If someone could get me started in the right direction I would greatly appreciate it.

-- Scott
Offline endolf

JGO Coder

Medals: 7
Exp: 15 years

Current project release date: sometime in 3003

« Reply #2 - Posted 2007-02-25 10:18:20 »


You can find the latests distributables here. The last one was build in October last year, but not a huge amount has changed since then.

The OSX build process is not something I can test as I have no Mac, so i'll leave that for someone else to help you with. I'm guessing Elias will be checking the forums at some point Smiley.


Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline elias

Senior Devvie

« Reply #3 - Posted 2007-02-25 11:40:00 »

It seems like your gcc 3.3 install is somehow broken. What version of XCode do you have? Do you have gcc-3.3 installed at all (not gcc-4)? Can you compile a simple hello world example with gcc-3.3?

 - elias

Offline Lareon

Senior Newbie

I program for fun... Isn't that weird?!?

« Reply #4 - Posted 2007-02-25 17:18:29 »


I tried the file you linked to, and it worked okay, though it ran into a problem while running...
ce = ControllerEnvironment.getDefaultEnvironment();
controllers = ce.getControllers();

The above code responded with this:
Failed to enumerate device: Device open failed: -536870203
So I'm not sure what to do about that from here.


You're right, I tried a simple program and it returned "gcc-3.3: installation problem, cannot exec `cc1': No such file or directory".  I'm running all o fthis on my Intel Mac, which as I recall doesn't COME with gcc-3.3, or something like that.  Do you know of a way to get it?  Or perhaps is there something else wrong entirely?

Thank you both so much for your quick responses!
-- Scott
Offline elias

Senior Devvie

« Reply #5 - Posted 2007-02-25 20:12:45 »

I only have ppc macs handy and using the gcc3 installer package from XCode worked here. You should check if it works on intel macs too.

 - elias

Offline elias

Senior Devvie

« Reply #6 - Posted 2007-02-25 20:44:46 »

And I've tweaked jinput to not let one device open failure to stop enumerating altogether. Fetch the new binaries here:

 - elias

Offline Lareon

Senior Newbie

I program for fun... Isn't that weird?!?

« Reply #7 - Posted 2007-02-26 01:27:23 »

Thanks, that works for me now! ^_^

As for gcc, I'm not really sure how that all changed, or why Apple mandates gcc4 for intel macs, but I'm reluctant to go messing about with it since the version you provided works just fine and I honestly don't know enough to feel comfortable changing things around like that.

Out of curiosity, when I iterate through the controllers and output their .getName() value, I see the mice (a mouse and stylus) and the controller, but then I see three more: "Controller Type: Mouse", then "Keyboard", then "Controller"...  So that looks like JInput found SIX devices (seven, if you count the one it couldn't open), but I only have four.  Is this expected?

(Sorry for redirecting the thread topic...)

Nevermind all that.  I checked my code and it turns out that I was already calling something to list the controller type when I added the code to list the other information beforehand. >.<  My bad.

-- Scott
Offline elias

Senior Devvie

« Reply #8 - Posted 2007-02-26 07:08:21 »

I'm glad it works for you now. You won't need gcc 3 now, but just in case others see this thread: On (at least PowerPC) macs, gcc 3 and gcc 4 can live happily side by side and won't step on each others toes. And gcc 4 has been the standard compiler since (I think) Mac OS X 10.4 on both ppc and intel. Jinput (and my other project, LWJGL) use gcc 3 only to build the ppc part of the universal library to make it compatible all the way down to Mac OS X 10.2. The intel part is compiled with gcc 4, since all intel macs have at least Mac OS X 10.4.

 - elias

Pages: [1]
  ignore  |  Print  
You cannot reply to this message, because it is very, very old.

Jesse (11 views)
2015-07-29 04:35:27

Riven (33 views)
2015-07-27 16:38:00

Riven (16 views)
2015-07-27 15:35:20

Riven (20 views)
2015-07-27 12:26:13

Riven (10 views)
2015-07-27 12:23:39

BurntPizza (28 views)
2015-07-25 00:14:37

BurntPizza (39 views)
2015-07-24 22:06:39

BurntPizza (22 views)
2015-07-24 06:06:53

NoxInc (26 views)
2015-07-22 22:16:53

NoxInc (17 views)
2015-07-22 22:13:39
List of Learning Resources
by gouessej
2015-07-09 11:29:36

How Do I Expand My Game?
by bashfrog
2015-06-14 11:34:43

List of Learning Resources
by PocketCrafter7
2015-05-31 05:37:30

Intersection Methods
by Roquen
2015-05-29 08:19:33

List of Learning Resources
by SilverTiger
2015-05-05 10:20:32

How to: JGO Wiki
by Mac70
2015-02-17 20:56:16

2D Dynamic Lighting
by ThePixelPony
2015-01-01 20:25:42

How do I start Java Game Development?
by gouessej
2014-12-27 19:41:21 is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!