Done. Had a great manual merging party today.. thanks Qudus
No just kidding.
I thought I was the only one working at this late time (for us Europeans).
But why did you delete the getRenderFrame() method in View ?
Hah, I saw you added a Renderer class. Gonna dig that a bit.
I didn't add this class. It was there before my recent changes. I just moved the rendering code from the View to the Renderer class and the Atom collecting code in the FrameAtomsCollector class which previously was named RenderFrame.
I always wondered what this RenderFrame class did when it didn't actually render. I browsed through the code and found out, that it actually sums up all the Atoms. So I renamed it to FrameAtomsCollector to make it clear to everyone what it actually does and moved the code from Renderer to it, which actually belongs to it. On the other side I moved the rendering code, which was residing in the View class into the Renderer class, since the View only describes a camera or an Eye and doesn't actually render anything.
I think this is much better understandable, isn't it. So we all can better comprehend how the rendering works.
The Renderer actually doen't render itself. It just flatens the scenegraph to Atoms which the actual renderer (OpenGL) can handle better.
I'll proceed this work now and maybe rename some more classes / methods to improve understandability and logical correctness of the code. After all I'll have a quite good understanding of the render process