The usual naming is createSomething rather than newSomething is it not? getSomething seems to be used where there is a backing cache and you don't expect it to return a unique instance.
The most intuitive name for me would be simply make(args) or create(args). No need for the extra word. Java is already clutered with unnecessary long names.
Ey, in your code you can do what you want, simply use create(), nobody restricts you there, if you think this is enough. But imagine you've got a factory-class that can create A-objects and B-objects. Then it would for sure be a good way to call the methods
A createA(); and
About this long name issue: I rather have long names than
PS: cnoiasw means createNewObjectInAShortWay