I actually enjoyed this article a lot. It touched on a lot of issues that plagues developers (even if they are too bold to admit it). The issues touched on are invaluable like knowing whether testing has a limit, having a feel on your contributions to the team, and knowing how to design good or bad code.
In my opinion, though, even variable verbosity can get to the point of where it is overboard. As a developer, it takes a lot more time to think about what makes for a good variable name, and some people have a varying sense to what makes it good.
this_post_taking_too_long = true
is great for knowing what it does, but then we end up having code that
in loops and nested functions. Sometimes just using
is better and more elegant.
Programmers definitely are lazy though. They'd be just as unwilling to change a bad variable, function, or class name as they would the comments that accompany them. It is still up to the programmer to make sure they are following up on their work and being vigilant.