Hi !
Featured games (91)
games approved by the League of Dukes
Games in Showcase (804)
Games in Android Showcase (237)
games submitted by our members
Games in WIP (867)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1] 2 3
  ignore  |  Print  
  Squareheads  (Read 22292 times)
0 Members and 1 Guest are viewing this topic.
Offline tom
« Posted 2003-12-16 16:03:43 »

Squareheads is a first person shooter, that I'm working on in my spare time. It's going to be multiplayer only game. Although I might try to make some boots.

A webstart demo can be found here:

Offline kevglass

« JGO Spiffy Duke »

Medals: 319
Projects: 25
Exp: 22 years

Coder, Trainee Pixel Artist, Game Reviewer

« Reply #1 - Posted 2003-12-16 16:28:57 »

Ok, its a little basic atm, but I think its pretty ace! No hassle, no problems.. just worked...

Keep it up!


Offline erikd

JGO Ninja

Medals: 16
Projects: 4
Exp: 14 years


« Reply #2 - Posted 2003-12-16 16:50:27 »

Cool stuff  Cool
I'm looking forward to seeing this progress!


Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline Matzon

JGO Knight

Medals: 19
Projects: 1

I'm gonna wring your pants!

« Reply #3 - Posted 2003-12-16 16:55:08 »

Worked perfectly, Love the avatar! Grin

Offline Seekely

Senior Newbie

I am java

« Reply #4 - Posted 2003-12-16 17:19:23 »

no problems, nice start  
An RPG like every other, except this one is made by me
Offline EgonOlsen
« Reply #5 - Posted 2003-12-16 19:33:35 »

Doesn't work for me. The window opens, everything is black and then it closes. That's on a P4@3.2Ghz, Radeon9700pro (Catalyst 3.9 drivers), WinXP home SP1, Java 1.4.2

Edit: Deleted the JWS caches and tried it again and now it works fine.

Offline markush

Senior Newbie


« Reply #6 - Posted 2003-12-16 20:13:52 »

Works great!

WinXP Pro, java 1.4.dontknow:), radeon 9700pro, athlon xp 2200, 1.5G Ram
Offline swpalmer

JGO Coder

Exp: 12 years

Where's the Kaboom?

« Reply #7 - Posted 2003-12-16 21:07:13 »

Does not work on Mac OS X (1.4.2DP1)

The application silently disappears when launched - no logs.
I suspect there is an exception thrown that is being caught without actually doing anything to handle the error.  tsk... tsk...

Offline tom
« Reply #8 - Posted 2003-12-16 22:44:26 »

Thank you all for testing the game!!

For those of you who did not get it to run. Please try again. I've added an error dialog that is shown if it crashes. If it shows (fingers crossed), please post the error message here.

Offline swpalmer

JGO Coder

Exp: 12 years

Where's the Kaboom?

« Reply #9 - Posted 2003-12-17 02:50:33 »


java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
     at java.lang.ClassLoader.loadLibrary(
     at java.lang.Runtime.loadLibrary0(
     at java.lang.System.loadLibrary(
     at org.lwjgl.Sys.initialize(Unknown Source)
     at org.lwjgl.Sys.<clinit>(Unknown Source)
     at org.lwjgl.opengl.Window.<clinit>(Unknown Source)
     at sh.SquareHeads.initLwjgl(
     at sh.SquareHeads.main(
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(
     at java.lang.reflect.Method.invoke(
     at com.sun.javaws.Launcher.executeApplication(
     at com.sun.javaws.Launcher.executeMainClass(
     at com.sun.javaws.Launcher.continueLaunch(
     at com.sun.javaws.Launcher.handleApplicationDesc(
     at com.sun.javaws.Launcher.handleLaunchFile(

Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline wiederke

Junior Devvie

Thx to James Gosling.

« Reply #10 - Posted 2003-12-17 08:41:56 »


runs GREAT!!!

I'm looking forward to see the full game.

ciao torsten
Offline tom
« Reply #11 - Posted 2003-12-17 09:41:04 »

Looks like I made a copy and past mistake in the signing script. The windows dll was used instead of the osx jnilib  Embarrassed

I've corrected it now, if you wan't to have another go. I think the game will work on a mac. Although, wasn't there a problem with buffered keyboard input when using lwjgl on a mac?

Offline Markus_Persson

JGO Wizard

Medals: 19
Projects: 19

Mojang Specifications

« Reply #12 - Posted 2003-12-17 09:57:18 »

Woo, works very well. =D

Kinda hard to actually get a kill in it though. =)

Play Minecraft!
Offline swpalmer

JGO Coder

Exp: 12 years

Where's the Kaboom?

« Reply #13 - Posted 2003-12-17 11:39:00 »

Ok launches now on Mac  (had to delete the app and re-install since WebStart did not pick up an updated JAR)


- No mouse cursor..  I had to watch for the hover highlighting to know when i was over a button.

- Only uses built-in track pad of my powerbook, I have a USB mouse connected (impossible to play this style with a trackpad).  AlienFlux does work with the external mouse so this shouldn't be a limitation of LWJGL.

- Couldn't move, so I assume what you were saying about keyboard support on Mac in LWJGL might be true... I will have to fire up Alien Flux again to confirm that.. i assumed it was fixed though since AF announced the Mac release.

Offline tom
« Reply #14 - Posted 2003-12-17 11:57:29 »

I use the hardware mouse cursor in lwjgl. But I did implement this very quickly. So I don't rescale the mouse cursor if it do not match the supported min/max size. So probably the cursor size on mac is not 32x32 and it fails. I do print it out though. So you could check it out, if you look at the java console. I'm going to fix this...eventally  Wink

Either that or hardware mouse cursor is not supported.

I don't do anything special with the mouse except using the hardware cursor. Don't know why it does not use your mouse.

w,a,s and d uses polling, so that should work. I only use buffered input on [space] and [esc].

Btw. I use lwjgl 8.0 that I downloaded a month ago. So there might be some fixes in cvs that I don't have.

Offline swpalmer

JGO Coder

Exp: 12 years

Where's the Kaboom?

« Reply #15 - Posted 2003-12-17 14:17:38 »

W,A,S,D  did not work.
*edit* I didn't see any print out about the cursor.. but that may be an issue with my Web Start client.

Offline tom
« Reply #16 - Posted 2004-01-10 11:35:58 »

A new version is out with the following changes:
-ai players
-frag limit

Offline MickeyB

Senior Devvie

my game will work, my game will work!

« Reply #17 - Posted 2004-01-10 21:39:14 »

very nice!!!  Makes my CubeWars look sad.  Smiley

Keep it up!


Current Project:
Offline tom
« Reply #18 - Posted 2004-01-27 17:10:07 »

To save time I've decided to use the q3bsp as the level file format. I've started on the viewer, but there will be some time before I can release a demo of it. But until then I've made some screenshots you can look at:

Q3 shaders are for the most part implemented. This allows for effects like environment mapping, texture coord animation, vertex animation, misc blending etc.

I've not implemented fog nor collision detection agains bezier patches. Don't know if I'll bother putting it in.

The renderer is not optimized. I don't use multitextureing, and I only use glVertex3f, glTexCoord etc. The only optimization I've done is to minimise texture binds. Quake is more than 4 times as fast as my viewer  Cry Will be difficult to get close to that.

Offline Conzar

Junior Devvie

There is nothing common about common sense

« Reply #19 - Posted 2004-01-29 02:00:40 »

Works fine in Redhat 9.0

8: Undefined index: online
File: /home/jgo/public_html/Themes/default/Display.template.php (main sub template - eval?)
Line: 161