Hi !
Featured games (91)
games approved by the League of Dukes
Games in Showcase (808)
Games in Android Showcase (239)
games submitted by our members
Games in WIP (872)
games currently in development
News: Read the Java Gaming Resources, or peek at the official Java tutorials
    Home     Help   Search   Login   Register   
Pages: [1]
  ignore  |  Print  
  Elder Scrolls Explorer  (Read 14670 times)
0 Members and 1 Guest are viewing this topic.
Offline philjord
« Posted 2015-11-18 22:58:12 »

This is a project I’ve worked on in my spare time for about ten years now. It is approaching a level where I think people might be interested in seeing what I’ve done; specifically what can be done in pure java, and possibly the code might help someone.

It is a pure java, open source project.

It uses Jogamp’s Java3d for the scene graph and Jogamp’s Jogl for the render bindings
It uses JBullet for physic simulation
I’ve relied heavily on the NifTools team for decryption of models.
I am enormously grateful to the above teams/people for what they have done and the entire modding community generally are just awesome.

The video:
<a href=";hl=en_US&amp;start=" target="_blank">;hl=en_US&amp;start=</a>

The binaries:
(you need to have access to the game data files)

And finally the source code:
Offline EgonOlsen
« Reply #1 - Posted 2015-11-18 23:09:32 »

I would love to try this, but it doesn't seem to work for me. I tried it with the skyrim data files and it seems to process them just fine, but there's no render output. Just a blank rectangle in the size of the selected resolution and neither disk or cpu activity. Here are the logs, if that helps:

VERSION: ElderScrollsExplorer-2-25
LWJGL added to class path
BSA File Set loading F:\Programme\Steam\SteamApps\common\skyrim\Data\Skyrim - Animations.bsa
BSA File Set loading F:\Programme\Steam\SteamApps\common\skyrim\Data\Skyrim - Interface.bsa
BSA File Set loading F:\Programme\Steam\SteamApps\common\skyrim\Data\Skyrim - Meshes.bsa
BSA File Set loading F:\Programme\Steam\SteamApps\common\skyrim\Data\Skyrim - Misc.bsa
BSA File Set loading F:\Programme\Steam\SteamApps\common\skyrim\Data\Skyrim - Shaders.bsa
BSA File Set loading F:\Programme\Steam\SteamApps\common\skyrim\Data\Skyrim - Sounds.bsa
BSA File Set loading F:\Programme\Steam\SteamApps\common\skyrim\Data\Skyrim - Textures.bsa
BSA File Set loading F:\Programme\Steam\SteamApps\common\skyrim\Data\Skyrim - Voices.bsa
BSA File Set loading F:\Programme\Steam\SteamApps\common\skyrim\Data\Update.bsa
organising resolution...
FOV set to  80.0
setSceneAntialiasingEnable true
Persistent Records loaded in 288 WRLD count = 37 CELL count = 590 record count = 41433
[0x7FFA10014450] ANOMALY: meaningless REX prefix used

VERSION: ElderScrollsExplorer-2-25
Nov 19, 2015 12:06:14 AM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
3D [dev] 1.6.0-pre12-daily-experimental daily

AL lib: (EE) alc_cleanup: 1 device not closed

This is on Windows 10 64bit using a Radeon R9 290X...

Offline philjord
« Reply #2 - Posted 2015-11-18 23:25:32 »

Unfortunately I haven't seen error before
ANOMALY: meaningless REX prefix used
shows lots of Java Windows 10 graphics driver issues, including JavaFX and minecraft

The high med low lines are mine.

Can you run the ResolutionTest.bat file in the launch directory? And send what it outputs to me?

I suspect it will show the same thing. In which case it's update drivers/update java/cross fingers...

Can you also tell me what version of java it's running using Check java.bat

Finally if it's the java version casuing trouble you can drop a jre folder (and the jre) into the same folder as the ElderScrollsExplorer, in which case it will use that.
EDIT: don't use teh above it's for paying Oracle customers only, use the link below /EDIT

 I also notice that a number of people mention disabling AVG antivirus software can fix it
and one mentions un-installing "gaming evolved/raptr" whatever that is from AMD

Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline EgonOlsen
« Reply #3 - Posted 2015-11-19 06:23:35 »

The resolution test just outputs this into the console:

C:\Users\EgonOlsen\Desktop\ElderScrollsExplorer v2.25\ElderScrollsExplorer>java  -Dsun.java2d.noddraw=true -cp .\ElderScrollsExplorer.jar;.\lib\jogamp\jar\gluegen-rt.jar;.\lib\jogamp\jar\jogl-all.jar;.\lib\java3d\1.6.0-pre12\j3dcore.jar;.\lib\java3d\1.6.0-pre12\j3dutils.jar;.\lib\java3d\1.6.0-pre12\vecmath.jar;.\lib\j3d-org-java3d-all.jar;   tools3d.resolution.ResolutionTest
3D [dev] 1.6.0-pre12-daily-experimental daily

organising resolution...
[0x7FFA0F614450] ANOMALY: meaningless REX prefix used

But it works just fine. Java version is 1.8.0_25, driver is the latest and greatest. I've no problems running anything else with them and that includes a lot of Java/OpenGL related stuff. I'm not using AVG antivirus. Disabling my antivirus doesn't help anything either.

Offline philjord
« Reply #4 - Posted 2015-11-19 08:06:42 »

Ok, if you're seeing the spinning triangle then you are definitely past the hardest issue, the one where I give you that awful advice to update everything and hope. (sorry about that).

I'll put a new version up on the download page later today with more debug output.

I'm wondering if it's a stencil or depth buffer issue somehow.

Can you do me another favor?

Java 1.7 and 1.8 is troublesome for Java3d/JoglPipeline, can you unzip this jre
into the ElderScrollsExplorer folder
edit the ResolutionTest.bat file so on the second line the starting java becomes jre\bin\java

Then run ResolutionTest.bat and click the Props button and send me the output

(That button will crash with Java 1.8 )

If you want you could give ElderScrollsExplorere.jar another go too, it will use the 1.6 jvm.

Thanks for your patience on this...

Offline philjord
« Reply #5 - Posted 2015-11-19 08:40:33 »

Now I think about it perhaps I'm asking the wrong questions entirely!!!

I'm so used to 3d problems I didn't even check where you are up to.

Once you click Skyrim the bsa files and the esm load up (as can be seen in your output)

Are you then looking at a screen like this? Possibly behind the display window.

If not then the problem is not graphical (woo hoo), and I'll still be making a debug version

If so did you click one of the items in the table?
Offline EgonOlsen
« Reply #6 - Posted 2015-11-19 10:27:17 »

I'll try with the older Java version later today. And yes, I'm seeing this table populated with all that stuff. I don't remember if I've clicked on anything inside it though.

Offline philjord
« Reply #7 - Posted 2015-11-19 12:48:32 »

Cool, it loads up the Cell you select, generally an INT cell is a lot smaller adn faster to load.

Don't bother with JRE 1.6 until you've seen what happens when you click a cell.

The 5 labels at the bottom light up based on what it's doing so if any of them is red then it's still loading.

Offline CodeMason
« Reply #8 - Posted 2015-11-19 13:05:02 »

Wow, this is really impressive, and great job!  Grin  It's also really nice that it's opensource as well.
Offline EgonOlsen
« Reply #9 - Posted 2015-11-19 17:00:47 »

...until you've seen what happens when you click a cell.

OK, clicking these entries does...something. It renders a scene now, but I'm not sure if it's looking correctly. No matter what I click, it looks more or less like this: Depending on the clicked entry, I can see some model in the center of the scene. But I'm placed inside of it most of the time, so all I'm seeing are some polygons' backsides.

Games published by our own members! Check 'em out!
Legends of Yore - The Casual Retro Roguelike
Offline philjord
« Reply #10 - Posted 2015-11-19 17:33:57 »

That fantastic, it looks like it working as it should.

However you have to be somewhere sensible for the world to look right. Generally it's best to use doors to change from one cell to another as they place you at the exit door.

So the best place to start is Cell 60 (Tamriel). If you click that and you at at 0, 0, 0 you'll be in the sky above some giants able to see white run.

First click on the display and pres tab to enable mouse look (tab again to release your mouse).
You can look around.
Now press F to freefly ( allow up/down and go through walls) and hold Z until you are very near the ground (Q to go up again)

Once you are down near ground press F again and the physics will drop you happily onto the ground.

Use the same system whenever you are behind the walls etc.

Then you can walk around and open doors and gates and generally look around. (use E to move fast).

There's more info in the user guide available from the menu bar.

Thanks for sticking with it, I'm pleased it works on your machine.

Offline philjord
« Reply #11 - Posted 2015-11-19 19:37:27 »

Thanks for the feedback, I see now I've been coding it too long and assume a lot.
I've made a small update so it automatically loads the primary cell and puts you some where interesting, if it's the first time you've run the engine (code?).
Offline EgonOlsen
« Reply #12 - Posted 2015-11-19 21:18:59 »

Didn't work for the first time, but seems to work somehow now...I'll test it some more and report back.

Offline EgonOlsen
« Reply #13 - Posted 2015-11-19 21:58:54 »

Yep, works fine now! It's a little choppy and I had to increase the mx to 1800mb to be able to travel a littel further without running into constant garbage collection stalls, but apart from that it was fine. I remembered quite a few locations from my Skyrim playthrough from 4 years ago and I walked around until I found the birch tree woods, because I liked them so much in Skyrim.

Just out of interest: What's the actual purpose of this? Is there any apart from having fun doing it? Is this a tool for something?

Offline philjord
« Reply #14 - Posted 2015-11-19 22:23:11 »

That's good to hear.

I'm surprised you managed to up the memory, what with my convoluted bootstrapping system (so it'll run on OSX out of the box, and do auto updates).

I love game design, but I discovered many years ago if you didn't have the source code for the engine and a massive pile of art assets game design is just pencil and paper. So I embarked on making and engine to allow me to make a game.

Now I've got it this far my plan is to turn my attention to the actual game-play.

But I wanted to offer my code to other devs in case it helps some newer (or older?) coders to get past the thousands of brick walls one faces.

Anyway thanks again for checking it out, please do send through anymore thoughts/problems.
Offline Gornova
« Reply #15 - Posted 2015-11-20 10:15:22 »

really really interesting and opensource, well done!

Blog | Last game Number+
Offline gouessej
« Reply #16 - Posted 2015-11-21 11:59:05 »

Java 1.7 and 1.8 is troublesome for Java3d/Jogl, can you unzip this jre
JOGL works flawlessly with Java 1.5, 1.6, 1.7, 1.8 and 1.9. Java3D is to blame. Please be accurate.

Edit.: Some virus scanners wrongly report an executable used within JOGL 2 as a virus, sorry for the disturbance.

Julien Gouesse | Personal blog | Website | Jogamp
Offline philjord
« Reply #17 - Posted 2015-11-21 14:35:14 »

A fair point, modified for accuracy...
Offline dentmaged

Senior Newbie

Medals: 1

« Reply #18 - Posted 2015-12-18 18:45:47 »

This looks so cool!

Sadly, I don't have any Bethesda studio games, but, this is incredible!
Offline philjord
« Reply #19 - Posted 2015-12-19 00:48:14 »

Thanks dentmaged. I'm working hard to make the Fallout 4 world exploreable and nice looking.

You really should play the Bethesda games  Grin especially Morrowind (though these days it looks to awful to play)

I think they're great and the old ones can be bought cheap these days, sometimes.
Pages: [1]
  ignore  |  Print  

Riven (845 views)
2019-09-04 15:33:17

hadezbladez (5786 views)
2018-11-16 13:46:03

hadezbladez (2602 views)
2018-11-16 13:41:33

hadezbladez (6202 views)
2018-11-16 13:35:35

hadezbladez (1498 views)
2018-11-16 13:32:03

EgonOlsen (4732 views)
2018-06-10 19:43:48

EgonOlsen (5788 views)
2018-06-10 19:43:44

EgonOlsen (3274 views)
2018-06-10 19:43:20

DesertCoockie (4174 views)
2018-05-13 18:23:11

nelsongames (5500 views)
2018-04-24 18:15:36
A NON-ideal modular configuration for Eclipse with JavaFX
by philfrei
2019-12-19 19:35:12

Java Gaming Resources
by philfrei
2019-05-14 16:15:13

Deployment and Packaging
by philfrei
2019-05-08 15:15:36

Deployment and Packaging
by philfrei
2019-05-08 15:13:34

Deployment and Packaging
by philfrei
2019-02-17 20:25:53

Deployment and Packaging
by mudlee
2018-08-22 18:09:50

Java Gaming Resources
by gouessej
2018-08-22 08:19:41

Deployment and Packaging
by gouessej
2018-08-22 08:04:08 is not responsible for the content posted by its members, including references to external websites, and other references that may or may not have a relation with our primarily gaming and game production oriented community. inquiries and complaints can be sent via email to the info‑account of the company managing the website of java‑
Powered by MySQL Powered by PHP Powered by SMF 1.1.18 | SMF © 2013, Simple Machines | Managed by Enhanced Four Valid XHTML 1.0! Valid CSS!